解決しない問題との奮闘

前回の記事でも言ってるとおり、RubytterがRuby1.9で動かない問題と奮闘しているわけですが・・。
どうやら、gemでインストールできるjsonライブラリに問題があるらしい。
Rubytterで使っているjsonライブラリがRuby1.9で動かないらしい。
Rubytter自体は1.9でも、問題なく動きます。
その証拠に、jsonがエラーを吐いたのにもかかわらず、Twitterにポストが出来ていることが確認できました。

うむぅ・・このままだと精神が持たないかもしれませんね。
よく考えれば、Pythonとかやったことないくせに、いきなりRubyやるなんてハードル高かったかなぁとか思えてきました。
独学するにも、BOTが作れる程度の知識だけ身につけばいいので、深く学習することなんて考えていません。
かといって、詳しく学ばないと、Rubyの仕組みがわからず、コーディングで詰まってしまいます。
しばらく奮闘して、だめなら、開発言語をPHPに変えることも検討しています。
あっちの方が情報豊富だし、すぐに作れそうですしね。
奮闘はまだまだ続く・・・。

スポンサードリンク
Pocket

Comments are closed.